Slowness in System
Incident Report for FormFire
Resolved
The issue was identified and corrected. Please email support@formfire.com if you continue to see any performance issues.
Posted Oct 02, 2018 - 11:59 EDT
Update
We are continuing to investigate this issue.
Posted Oct 02, 2018 - 11:58 EDT
Investigating
We've received reports of extended page load times and time out errors. We are currently investigating.
Posted Oct 02, 2018 - 11:43 EDT
This incident affected: Broker Portal and Employee Portal.