FormFire applications are affected by a widespread outage at the provider.
Incident Report for FormFire
Resolved
This incident has been resolved at the provider.
Posted Sep 28, 2020 - 23:50 EDT
Investigating
We have put FormFire.com admin and employee sites into maintenance mode so that users will not experience errors due to the outage at our provider. The site will become available again once we confirm the issue is resolved. Updates will be posted as we receive them. Thank you for understanding.
Posted Sep 28, 2020 - 19:42 EDT
This incident affected: Broker Portal and Employee Portal.