Website offline
Incident Report for FormFire
Resolved
Our hosting provider has fixed the issue. We are back online.
Posted May 02, 2019 - 20:38 EDT
Identified
FormFire's hosting provider is experiencing outages which caused us to take our website offline to prevent further issues. We will update once resolved.
Posted May 02, 2019 - 17:17 EDT
This incident affected: Broker Portal and Employee Portal.